Forum breadcrumbs - You are here:ForumEVC2: User projectsX470 Taichi / EVC2
You need to log in to create posts and topics.

X470 Taichi / EVC2

12

Hi Elmor and fellas in general. 🙂

So I received my EVC2 and here's what I've got.

https://drive.google.com/open?id=1JQ0oh_51J4ghuXtE4tyRC_HSdQpuWQC0

Is it recommended to use the EVC2N4 SPI Booster Adapter on ASRock boards?

Clip is on its way.

I see the SPI-cable for Asus will most likely fit my board. (didn't try yet)

If so, what would be the right orientation of the cable side going to the EVC2N4 SPI Booster?

Now, would it be safe to try at all? Would it fry the BIOS chip if the pins aren't in the right place?

I see the cable being really convenient compared to the clip. So it would be worth trying. Unless the clip is really easy to work with and will stay in place, in such case I wouldn't even risk trying the cable.

Thank you 🙂

BTW: I just asked ASRock tech support for confirmation of the nature of the header and to confirm the location of the BIOS chip. Also I asked for the pinout of that header, if confirmed is the right one.

EDIT: I'm just testing the board and seeing if it has the latest FW. (got the latest EVC2N_0005.dfu and also software v1.0.1.0)

  • The device gets recognized as EVC2 in Win10, no problem there. LED on the board is on (red light)
  • I get this error "USBifVersion unsupported" right after launching EVC2
  • Immediately after I get constant NET framework errors. I assume I need to install some NET redist package, but I don't know which one.

EDIT: Tried installing NET 4.8 and windows tells me I already have a newer version. (cannot continue installation)

EDIT: The board has now FW 0005 and is up and running, no errors. All good.

So, assuming I eventually connect it. What should be the procedure in EVC2.exe?

I see several options but don't know which one should I choose.

I wanted to test things with an old ASUS Prime X370 I have. Then give it a go on my X470 Taichi if something ever goes wrong.

The thing is, I would rather have all this needed details now, to put them in the folder with the EVC2 in my laptop in case something happens I don't need to be guessing around.

Tried with my ASUS board with the ASUS SPI Cable.

EVC2 could find a BIOS in the flash chip. (selected generic winbound W25Q) the chip number is slightly different and it is 16MB (old BIOSes for this board are 16.38MB)

I saved the extracted file and it was indeed 16.38MB

I could also verify.

Here is an image of it. Please let me know if something in the settings is wrong and I should take some precautions. (for example, less than 1.8V Vcc)

https://drive.google.com/open?id=1KRfF9xOfa31CVq16OXGcahPZ8FsQ9BmZ

That's it right? Seems to be working fine, at least on the ASUS board. At this point I'm 60% sure the ASRock board works in the same way.

Can I assume writing is done also with the same settings that work while reading a chip?

I found the part number for the X470 Taichi BIOS chip.

All this is written over the chip.

MXIC X174838

MX25U25645GH100

84163316

https://drive.google.com/open?id=16oKH5xkGo51g90q3_cUqYw9vyF1-I-_Y

EVC2 supports it under "SP1" (MX25U25645G)...it defaults to 32MB...is that the case? All BIOSes I have from that board are 16.38MB

How is the best way to proceed with this?

Here's a pic from the header in the X470 Taichi.

Indeed I see an arrow pointing to the same PIN1 position as in the ASUS header in your pinouts post, being that PIN1 indeed disconnected in the ASUS cable.

At this point I'm 80% sure is the same header, same pinout.

https://drive.google.com/open?id=1u8E4v9aakdPeLwpdqcdNZROGIi0HyOu-

Hmm, the extracted BIOS from the X370 Pro is different in size than any of the official BIOSes for that board. Is that a problem? How should I get the exact same file size?

https://drive.google.com/open?id=1NeihiZ0ro3ZqkH5h6QCxxbiLa0ra9N3k

Hello, it seems to work well for you so far. 

  • It's recommended to use the SPI Booster adapter with all boards
  • Many boards use a 16 MB flash image but a 32 MB flash part for future proofing. If the current BIOS data is less than 16MB, the file size will usually be 16 MB and not 32 MB.
  • 16 MB = 16384 KB, which is probably why you see 16.38MB in some cases (16384/1000 instead of /1024).
  • Most vendors use a similar scheme for part numbers VV25XSSS where VV = Vendor (W = Winbond, MX = MXIC), 25 = SPI NOR Flash, X = Product segment, could indicate supply voltage for example, SSS = Size in MBit (256 = 256 MBit/8 = 32 MB).
  • Raw data read from the flash part should be saved in .ROM or .BIN format to indicate it's raw data. Normally the motherboard vendor will distribute the bios data in a .CAP (Capsule) file, which contains an additional header detailing which board the file is intended for and other metadata. This is why you see a 2 KB size difference between the original .CAP file and the data you read back. 
  • I don't have an Asrock X470 Taichi here to test, but I'm told the header is different both electrically and physically. Specifically it should be 1.27mm pitch between the pins, compared to 2.0 mm on the Asus header. Does the Asus cable physically fit on there?

I didn't try yet on the Taichi board. Just checking visually from afar now, it does look indeed a lot smaller than the ASUS header.

Alright then. I'll try with the clip. 🙂 Any remarks about orientation of the clip connection to the EVC2? It will go through a SOP16 to 8 converter though.

Thanks for all those juicy details 😀 I didn't think the part number could be read like RAM Dimm part numbers where you can basically know the capacity, speed and timings. I think I can figure it out from here.

Abut the saved file. Aha! I didn't think about the ROM format at all, the exported file had no extension and I just changed it to CAP

Thank you!!

Just one more question: If I flash a 16MB ROM on a 32MB Chip is it gonna work? Or do the Chip and BIOS need to match?

Can I flash one of the official CAP files into the chip?

I think I will ultimately do all this ONLY if something goes wrong some day (hopefully never). Not just for fun with my current working machine, it would be dumb if I do something wrong. If a flash fails one day and the board bricks, I have nothing to lose.

That of course, unless there is some juicy modded BIOS available in the future with unlocked things, then I will try an unofficial flash tool. (I've yet seen the Per CCX OC options mentioned around)...I bricked my first Prime X370 Pro with AFUDOS and it was a PITA. 🙂 Now I can feel more adventurous.

Normally the test clip will have a red wire which indicates pin 1, but the SOIC16 is a bit of a special case. As long as your clip looks like this, the instructions should match: https://www.aliexpress.com/item/32681208043.html Pin 1 on the IC is indicated by the circular dimple.

Flashing a 16 MB ROM to a 32 MB flash part should not be a problem, the rest of the flash will just by empty. The EVC2 software should automatically detect if a .CAP file is loaded and remove the header. This allows you to flash it directly to the chip. It works this way because the header is not actually written to the chip, it's just used by the vendor software to check if the file is valid. 

12