Forum breadcrumbs - You are here:ForumEVC2: User projects5500XT + IR35217
You need to log in to create posts and topics.

5500XT + IR35217

Hi,

Since eVc is compatible with IR35217, I've got the idea to give it a try with this 5500XT but since there isn't a public datasheet avaliable for this controller and i'm not completely sure if the pinout for this controller is the same of IR35201, so i'm asking for help! πŸ˜€

Card pics, it's a Gigabyte model:

View post on imgur.com

View post on imgur.com

View post on imgur.com

View post on imgur.com

 

 

Thanks in advanced!

Hello πŸ™‚Β 

On IR35217:

Pin#24 - SDA
Pin#25 - SCL

Should be here on your card:

Quote from elmor on 2020-02-22, 23:19

Hello πŸ™‚Β 

On IR35217:

Pin#24 - SDA
Pin#25 - SCL

Should be here on your card:

Nice, it worked! πŸ˜€

However each time the gpu pstate changes the vga driver seems to rewrite the settings to the values which are currently applied to Wattman.

For example, if you ran the GPU-Z Render Test and apply 1.4V via EVC it will stay at 1.4V until you close the render but if you start it again, it will start using the Wattman setting.

Perhaps lock the GPU always to highest pstate would fix that but unfortunately I didn't find a way to do that on Navi GPUs. :/

 

 

Β 

 

Quote from NoMS on 2020-02-23, 23:16

Nice, it worked! πŸ˜€

However, each time the card goes out of 3d mode (eg: loading in between FS GTs) it returns with wattman settings and I need to reapply the EVC Manual VID as soon as the benchmark starts. :/
Perhaps lock the GPU always to highest pstate would fix that but unfortunately I didn't find a way to do that on Navi GPUs.

I think I may know what's going on there, can you try this version? https://1drv.ms/u/s!Atmpv-6qHr_6u8UuNi7PCalOpw9xCA?e=GT8wjb

There should be 2 new options for IR35217 (I2C).

"Ignore 0V Command" = "Enabled" should always force the Manual VID

"Clear Gamer Mode on 0V Command" = "Enabled" should go into lower power states in idle, but go back to Manual VID when loaded

Quote from elmor on 2020-02-24, 12:34
Quote from NoMS on 2020-02-23, 23:16

Nice, it worked! πŸ˜€

However, each time the card goes out of 3d mode (eg: loading in between FS GTs) it returns with wattman settings and I need to reapply the EVC Manual VID as soon as the benchmark starts. :/
Perhaps lock the GPU always to highest pstate would fix that but unfortunately I didn't find a way to do that on Navi GPUs.

I think I may know what's going on there, can you try this version? https://1drv.ms/u/s!Atmpv-6qHr_6u8UuNi7PCalOpw9xCA?e=GT8wjb

There should be 2 new options for IR35217 (I2C).

"Ignore 0V Command" = "Enabled" should always force the Manual VID

"Clear Gamer Mode on 0V Command" = "Enabled" should go into lower power states in idle, but go back to Manual VID when loaded

I'm testing it right now! πŸ˜€

"Ignore 0V Command" = Working as intended.

"Clear Gamer Mode on 0V Command" = Shows the same behavior described in the previous post.

 

Thank you for testing, "Ignore 0V Command" solves the problem then?

Quote from elmor on 2020-02-25, 22:03

Thank you for testing, "Ignore 0V Command" solves the problem then?

Yes! πŸ™‚

I'm planning to try this card on dice soon, push more than 1.3V on water only makes things worse. :/

FS: https://hwbot.org/submission/4362329_